World Chain Chainlink Data Streams Updater Downtime
Resolved
Jul 21 at 09:11pm UTC
Summary
Two brief periods of downtime occurred on July 21, 2025, affecting Chainlink Data Streams feed updates on World Chain.
Timeline
- 14:02:59 to 14:06:33 PDT — 3 minutes 34 seconds
- 14:07:17 to 14:11:49 PDT — 4 minutes 32 seconds
Impact
During these windows, no Data Streams updates were successfully submitted for affected feeds.
The missed updates did not result in unjust liquidations or other downstream protocol issues.
Root Cause
A backward skew of ~5 seconds in the blockchain clock caused submitted reports to have a validFromTimestamp
later than the block timestamp, leading to reverts.
This same issue also impacted Chainlink’s official transmitter during the affected period.
Resolution
Once the clock skew resolved, feed updates resumed automatically.
A full investigation confirmed the cause and verified the absence of negative downstream effects.
Follow-Up Actions
- Blockchain clock skew detection and handling has been implemented in our infrastructure to prevent recurrence.
Affected services
Created
Jul 21 at 09:02pm UTC
Start of downtime.
Affected services